Export 3D modelů z Google Map

You are here:
Estimated reading time: 2 min

Úvodem

Tento návod je pouze informativní a web wikiquik.eu neodpovídá za vaší prováděnou práci! Nepřebírám odpovědnost za jakékoli použití tohoto nástroje.

 

Nejprve budeme potřebovat programy:

  • RenderDoc verze v1.9
  • Blender
  • A jako doplněk pro Blender: Maps Models Importer

RenderDoc

RenderDoc je bezplatný samostatný grafický debugger s licencí MIT, který umožňuje rychlé a snadné zachycení jednoho snímku a detailní introspekci jakékoli aplikace pomocí Vulkan, D3D11, OpenGL & OpenGL ES nebo D3D12 v systémech Windows 7-10, Linux, Android, Stadia nebo Nintendo Switch ™.

Stáhnout RenderDoc

Jakou stavbu chci? Stabilní verze jsou nejnovější nejstabilnější verze, které byly testovány, ověřeny a vydány s číslem verze. Ty se aktualizují v průměru jednou za měsíc nebo dva.

Maps Models Importer

Maps Models Importer je sada nástrojů pro import 3D modelů ze širokých map do 3D obsahového softwaru. Toto je důkaz koncepce obsahující pouze doplněk Blender pro import 3D modelů z Map Google.

Stáhněte si vydání nebo jej rozbalte blender/MapsModelsImporter/. V Blenderu 2.83, jděte na Edit > PreferencesAdd-onInstalla pak přejděte na zip souboru.

  1. Spusťte RenderDoc a File > Inject into process;

 

  1. Spusťte terminál (Win+R, „cmd“) a spusťte (přizpůsobte druhý řádek umístění instalace prohlížeče Chrome nebo Vivaldi):

Použití pro zástupce
C:\Windows\System32\cmd.exe /c "SET RENDERDOC_HOOK_EGL=0 && START "" ^"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe^" --disable-gpu-sandbox --gpu-startup-dialog"
Příkazový Řádek
set RENDERDOC_HOOK_EGL=0
"C:\Program Files\Google\Chrome\Application\chrome.exe" --disable-gpu-sandbox --gpu-startup-dialog
  1. V dialogovém okně zatím NEMAŽTE OK;

 

  1. V RenderDoc vyhledejte proces GPU chromu a vložte jej do něj (můžete použít vyhledávací pole);

 

  1. V satelitním zobrazení přejděte na Mapy Google (ne na Google Earth!) A pořiďte snímek pomocí Print Screen pohybu ve výřezu;

 

  1. V RenderDoc uložte zachycení jako soubor rdc

 

  1. V aplikaci Blender přejděte na File > Import > Google Maps Capturesoubor pro zachycení.

Pro krok 2. můžete vytvořit odkaz na Chrome, nikoli použít cmd, a zadat jako cíl (opět přizpůsobte cestu chrome.exevaší instalaci):

Jak zvýšit úroveň podrobností?

Pokud chcete kvalitnější snímky, měli byste vědět, že Mapy Google načítají LoD (úrovně podrobností) ve vztahu k velikosti okna vašeho webového prohlížeče. Existuje několik způsobů, jak ji zvýšit:

 

  • Můžete zvýšit rozlišení obrazovky. Všimněte si také, že nvidia nyní umožňuje zvýšit rozlišení vykreslování vaší obrazovky na 4k dokonce i na jednoduchém Full HD displeji.
  • V prohlížeči Google Chrome můžete také použít procento velikosti vykreslování. Většina prohlížečů nabízí možnost přiblížit nebo oddálit webové stránky (obvykle pomocí Ctrl+kolečko myši) a přizpůsobit je rozlišení obrazovky. Nastavením přiblížení např. Na 25% v prohlížeči Google Chrome zvýšíte úroveň podrobností načtených Mapami Google.
  • Vezměte několik úlovků a spojte je dohromady (viz další otázka)

Ale zároveň tím dramaticky zvýšíte počet bloků. Uvědomte si, že ve výchozím nastavení doplněk MapsModelsImporter omezuje na 200 bloků, aby se zabránilo příliš dlouhému zamrzání. Toto číslo můžete změnit při importu.

 

  • Chcete -li spojit všechny kusy do jedné sítě: A (pro výběr všech), Ctrl+J
  • Svařování vrcholů: Přepněte do režimu úprav (karta), M> Podle vzdálenosti.
  • Chcete -li nastavit měřítko na 1 bez změny velikosti geometrie: Ctrl+A> Měřítko

Nefunguje Chrome? Zkuste Vivaldi

Může se stát, že nové verze prohlížeče Chrome, vám neumožní navázat spojení s programem RenderDoc. Proto doporučuji si stáhnout prohlížeč Vivaldi, postup je stejný jak u Chrome, stačí pouze pozměnit adresu programu vivaldi.exe

Použití pro zástupce
C:\Windows\System32\cmd.exe /c "SET RENDERDOC_HOOK_EGL=0 && START "" ^"C:\Users\USER\AppData\Local\Vivaldi\Application\vivaldi.exe^" --disable-gpu-sandbox --gpu-startup-dialog"

Stáhnout určitou verzi Blender

Pokud potřebujete stáhnout verzi programu Blender navštivte tento link: https://download.blender.org/release/

Byl tento článek užitečný?
Dislike 0
Views: 17
Back to top button